Description
The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'update_block_style' endpoint in all versions up to, and including, 3.19.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Apply Patch
AI Analysis

Impact

The vulnerability exists in the Stackable – Page Builder Gutenberg Blocks WordPress plugin; the update_block_style endpoint does not properly sanitize or escape input, allowing a stored cross‑site scripting (XSS) payload to be written into block styles. An attacker who is authenticated with contributor‑level or higher privileges can inject arbitrary scripts that execute whenever a user loads the affected page. The CVSS score of 6.4 indicates a moderate impact level for web‑based attacks.

Affected Systems

All releases of Stackable – Page Builder Gutenberg Blocks up to and including version 3.19.9 on WordPress sites are vulnerable. The issue is confined to the plugin component and does not affect the core WordPress installation.

Risk and Exploitability

The vulnerability requires authenticated access at contributor level or higher, a privilege that is often granted to content authors or editors. The lack of input validation creates a stored XSS vector where a malicious script is permanently saved into a page’s block style and subsequently executed for any user who views that page. The EPSS score is not available and the vulnerability is not listed in the CISA KEV catalogue, so the likelihood of widespread exploitation is currently uncertain, yet the potential for user‑privilege escalation and phishing remains.

Generated by OpenCVE AI on November 7, 2026 at 08:44 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Stackable – Page Builder Gutenberg Blocks to version 3.20.0 or later, which blocks the vulnerable endpoint.
  • If an update is not yet available, restrict contributor or higher roles from accessing block‑style editing features, or remove the vulnerable capability from their role set.
  • Deploy a Content Security Policy (CSP) that limits script execution to trusted sources on your domain to mitigate the impact of an exploit.

Generated by OpenCVE AI on November 7, 2026 at 08:44 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
Link Providers
https://github.com/gambitph/Stackable/pull/3725 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L155 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L181 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L223 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L432 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L155 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L181 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L223 cve-icon cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L432 cve-icon cve-icon
https://plugins.trac.wordpress.org/changeset/3609541/stackable-ultimate-gutenberg-blocks/trunk/src/deprecated/block-defaults/custom-block-styles.php cve-icon cve-icon
https://www.wordfence.com/threat-intel/vulnerabilities/id/1d4da874-23c8-4df4-b776-6046ce8d705a?source=cve cve-icon cve-icon
History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'update_block_style' endpoint in all versions up to, and including, 3.19.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Stackable <= 3.19.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'save' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T04:27:12.469Z

Reserved: 2026-05-26T15:34:01.308Z

Link: CVE-2026-9601

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T05:19:03.353

Modified: 2026-11-07T05:19:03.550

Link: CVE-2026-9601

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T08:45:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')