Description
Uncontrolled Recursion vulnerability in Apache Thrift PHP bindings.



This issue affects Apache Thrift: before 0.25.0.



Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Published: 2026-10-02
Score: 8.2 High
EPSS: < 1% Very Low
KEV: No
Impact: Denial of Service
Action: Immediate Patch
AI Analysis

Impact

Apache Thrift PHP bindings expose an uncontrolled recursion flaw in the struct readers generated with the `--gen php:inlined` option and in the `TProtocol::skipBinary` function. Because no recursion‑depth guard exists, a maliciously crafted Thrift payload can trigger an infinite recursive descent, causing a stack overflow or exhausting system resources. The flaw is a classic example of CWE‑674 (Uncontrolled Recursion) and can allow an attacker to crash the Thrift server or client, leading to a denial of service.

Affected Systems

The vulnerability affects Apache Thrift implementations from the Apache Software Foundation that are older than version 0.25.0. All releases before 0.25.0 are impacted. Users are advised to upgrade to the 0.25.0 release or later to eliminate the issue.

Risk and Exploitability

The CVSS score of 8.2 classifies the flaw as high severity. EPSS data is not available, so the current exploitation probability is unknown. The vulnerability is not listed in the CISA KEV catalog. Attackers can exploit the defect by sending specially crafted Thrift messages to a PHP service that uses the vulnerable bindings, which can trigger uncontrolled recursion in the parser and cause a stack overflow, crashing the process and rendering the service unavailable. The flaw requires network access to the Thrift service and does not require privileged local access.

Generated by OpenCVE AI on October 2, 2026 at 13:32 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Apache Thrift to version 0.25.0 or newer.
  • Restrict access to the Thrift service to trusted networks or IP addresses to reduce exposure.
  • Add application‑level validation of incoming Thrift data to detect overly deep or malformed structures before processing.

Generated by OpenCVE AI on October 2, 2026 at 13:32 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 04 Oct 2026 22:15:00 +0000

Type Values Removed Values Added
First Time appeared Apache
Apache thrift
Vendors & Products Apache
Apache thrift

Fri, 02 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 02 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Description Uncontrolled Recursion vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Title Apache Thrift: php `--gen php:inlined` struct readers (and `TProtocol::skipBinary`) have no recursion-depth guard
Weaknesses CWE-674
References
Metrics cvssV4_0

{'score': 8.2, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-10-02T12:30:18.926Z

Reserved: 2026-09-22T21:21:44.783Z

Link: CVE-2026-96289

cve-icon Vulnrichment

Updated: 2026-10-02T12:30:12.723Z

cve-icon NVD

Status : Deferred

Published: 2026-10-02T13:18:05.977

Modified: 2026-10-02T14:30:28.440

Link: CVE-2026-96289

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-04T20:54:12Z

Weaknesses