Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yalla ya! Simple Payment simple-payment allows Reflected XSS.This issue affects Simple Payment: from n/a through 2.5.4.
Published: 2026-10-09
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yalla ya! Simple Payment simple-payment allows Reflected XSS.

Affected Systems

The vulnerability exists in the yalla ya! Simple Payment WordPress plugin for all versions up to and including 2.5.4. Users who have not upgraded beyond 2.5.4 are directly affected. There is no information indicating that later versions are impacted.

Risk and Exploitability

The CVSS score of 7.1 indicates moderate‑to‑high severity. The EPSS score is not available, so the current exploitation probability is unknown, and the vulnerability is not listed in CISA’s KEV catalog.

Generated by OpenCVE AI on October 9, 2026 at 12:27 UTC.

Remediation

Vendor Solution

Update the WordPress Simple Payment plugin to the latest available version (at least 2.5.6).


OpenCVE Recommended Actions

  • Update the Simple Payment plugin to version 2.5.6 or later.
  • If an immediate update is not possible, disable the Simple Payment plugin to prevent exploitation.
  • Implement server‑side input sanitization or a Web Application Firewall rule to filter out script tags for all input fields.

Generated by OpenCVE AI on October 9, 2026 at 12:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 10 Oct 2026 20:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yalla ya! Simple Payment simple-payment allows Reflected XSS.This issue affects Simple Payment: from n/a through 2.5.4.
Title WordPress Simple Payment plugin <= 2.5.4 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-09T20:06:18.069Z

Reserved: 2026-09-23T00:18:19.472Z

Link: CVE-2026-96332

cve-icon Vulnrichment

Updated: 2026-10-09T20:06:13.963Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T10:16:44.320

Modified: 2026-10-09T21:17:07.847

Link: CVE-2026-96332

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T12:30:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')