Description
The User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpuf_payment_method' parameter in all versions up to, and including, 4.3.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The bypass technique involves appending a valid gateway keyword such as 'bank' to the HTML payload, causing sanitize_text_field() to yield only the keyword for routing purposes while the full malicious raw value is stored and later rendered unescaped.
Published: 2026-10-10
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Authenticated Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The CVE describes a stored Cross‑Site Scripting vulnerability in the Wedevs User Frontend plugin. An authenticated user who has subscriber level access or higher can inject arbitrary JavaScript into the 'wpuf_payment_method' parameter. Because the plugin uses the sanitize_text_field() function to isolate the gateway keyword but stores the full raw value, the malicious script is saved without proper escaping and later rendered unescaped in the page. This allows script execution in the context of any visitor who views the affected page.

Affected Systems

WordPress installations that use the Wedevs User Frontend plug‑in with any released version up to and including 4.3.12 are affected. Versions newer than 4.3.12 are not impacted by this flaw.

Risk and Exploitability

The CVSS score of 6.4 indicates a medium severity. EPSS data is not available, and the vulnerability is not listed in the CISA KEV catalogue. The flaw requires that the attacker be able to log in with subscriber level or higher privileges. An attacker can craft a malicious payload, submit it through the payment method field, and any subsequent display of that value will trigger the attack. Because the vulnerability is server‑side stored, exploitation will affect all users who view the corrupted content.

Generated by OpenCVE AI on October 10, 2026 at 09:08 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Wedevs User Frontend plug‑in to any version newer than 4.3.12.
  • If an upgrade cannot be applied immediately, restrict the ability of subscribers to set or modify the 'wpuf_payment_method' value, or enforce server‑side validation to allow only known gateway keywords.
  • Ensure that any stored 'wpuf_payment_method' data is correctly escaped with WordPress escaping functions before outputting it to the page.

Generated by OpenCVE AI on October 10, 2026 at 09:08 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpuf_payment_method' parameter in all versions up to, and including, 4.3.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The bypass technique involves appending a valid gateway keyword such as 'bank' to the HTML payload, causing sanitize_text_field() to yield only the keyword for routing purposes while the full malicious raw value is stored and later rendered unescaped.
Title User Frontend <= 4.3.12 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'wpuf_payment_method' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-11T12:23:56.023Z

Reserved: 2026-09-23T13:27:27.250Z

Link: CVE-2026-96574

cve-icon Vulnrichment

Updated: 2026-10-11T12:14:20.228Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T07:16:42.627

Modified: 2026-10-13T13:30:21.620

Link: CVE-2026-96574

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-10T09:15:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')