Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basix NEX-Forms nex-forms-express-wp-form-builder allows Reflected XSS.This issue affects NEX-Forms: from n/a through 9.3.1.
Published: 2026-10-09
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting (XSS)
Action: Apply Patch
AI Analysis

Impact

This vulnerability arises from improper neutralization of user input when generating web pages, leading to reflected XSS. An attacker can embed malicious scripts that are executed within the victim's browser when they view the affected form. Such scripts may perform actions such as stealing session cookies, defacing the site, redirecting users to phishing pages, or executing other client‑side attacks. The impact is primarily on confidentiality and integrity of user sessions, and can undermine user trust in the website.

Affected Systems

The flaw exists in the Basix NEX‑Forms plugin for WordPress, affecting all releases up to and including version 9.3.1 of the NEX‑Forms Express WP Form Builder. Users running any of those versions are potentially vulnerable.

Risk and Exploitability

The CVSS score of 7.1 reflects a medium‑high severity and indicates that the vulnerability can be exploited remotely by an attacker, although it requires the victim to visit a crafted URL or otherwise trigger the form. EPSS data is not available, so the probability of exploitation is unknown, and the vulnerability is not listed in the CISA KEV catalog. Because the flaw relies on reflected XSS, the attack is usually limited to the victim’s browser; however, sophisticated attackers could combine it with social engineering or other phishing tactics to increase impact. Organizations with high public visibility or a large number of visitors should treat this as a significant risk until mitigated.

Generated by OpenCVE AI on October 9, 2026 at 12:27 UTC.

Remediation

Vendor Solution

Update the WordPress NEX-Forms plugin to the latest available version (at least 9.3.2).


OpenCVE Recommended Actions

  • Upgrade the WordPress NEX‑Forms plugin to version 9.3.2 or later.
  • If the upgrade cannot be performed immediately, disable the plugin or restrict form access to internal users only to prevent exposure.
  • Review all custom form content and embedded JavaScript to ensure proper escaping and sanitization, and consider implementing a web application firewall that blocks XSS payloads.

Generated by OpenCVE AI on October 9, 2026 at 12:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basix NEX-Forms nex-forms-express-wp-form-builder allows Reflected XSS.This issue affects NEX-Forms: from n/a through 9.3.1.
Title WordPress NEX-Forms plugin <= 9.3.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-09T17:39:12.169Z

Reserved: 2026-09-23T14:00:08.537Z

Link: CVE-2026-96607

cve-icon Vulnrichment

Updated: 2026-10-09T17:39:06.839Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T10:16:45.557

Modified: 2026-10-09T18:17:16.483

Link: CVE-2026-96607

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T12:30:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')