Description
The Post Grid Gutenberg Blocks – PostX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via display_name User Field in all versions up to, and including, 5.1.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. WordPress core's pre_user_display_name filter encodes &, <, and > but leaves double-quotes intact (ENT_NOQUOTES), allowing a Subscriber-level user to store a double-quote in their display_name via /wp-admin/profile.php that subsequently breaks out of the alt="" attribute at Archive_Title.php:144.
Published: 2026-10-10
Score: 7.2 High
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The Post Grid Gutenberg Blocks – PostX plugin contains cross‑site scripting flaw that allows a user to inject arbitrary JavaScript into pages that use the Archive_Title block. The vulnerability arises from insufficient sanitization of the user’s display_name field, which can include a double quote that breaks out of an alt attribute. Once injected, any user visiting an affected page will execute the attacker’s code, potentially compromising session data, defacing content, or redirecting traffic.

Affected Systems

WordPress installations that use the Post Grid Gutenberg Blocks – PostX plugin, including all releases up to and including version 5.1.0. Users of newer releases are not affected.

Risk and Exploitability

The flaw is rated CVSS 7.2, indicating a high severity impact with relatively straightforward exploitation. An attacker only needs to create or edit a subscriber account’s display_name through the WordPress admin profile page. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog. Because the injected script runs in the context of every visitor to the affected page, the threat surface is high for sites that expose the Archive_Title block publicly.

Generated by OpenCVE AI on October 10, 2026 at 08:47 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Post Grid Gutenberg Blocks – PostX plugin to version 5.1.1 or later, which removes the vulnerability.
  • Verify after the update that all Archive_Title pages are free from injected script payloads by testing the alt attribute rendering.
  • If an immediate update is not possible, restrict user accounts from including double quotes in the display_name field by applying a sanitization filter or enforcing a stricter input policy.

Generated by OpenCVE AI on October 10, 2026 at 08:47 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Post Grid Gutenberg Blocks – PostX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via display_name User Field in all versions up to, and including, 5.1.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. WordPress core's pre_user_display_name filter encodes &, <, and > but leaves double-quotes intact (ENT_NOQUOTES), allowing a Subscriber-level user to store a double-quote in their display_name via /wp-admin/profile.php that subsequently breaks out of the alt="" attribute at Archive_Title.php:144.
Title Post Grid Gutenberg Blocks <= 5.1.0 - Unauthenticated Stored Cross-Site Scripting via display_name User Field
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-11T12:23:55.907Z

Reserved: 2026-09-23T17:59:22.479Z

Link: CVE-2026-96840

cve-icon Vulnrichment

Updated: 2026-10-11T12:14:12.958Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T07:16:42.767

Modified: 2026-10-13T13:30:21.620

Link: CVE-2026-96840

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-10T09:00:03Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')