Description
The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 1.12.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is triggered when any user hovers over a comment's like counter on a community page, as the plugin's tooltip handler assigns the attacker-controlled data-tooltip-description attribute value directly to innerHTML, re-parsing the browser-decoded entity payload as live HTML.
Published: 2026-10-16
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to a stored cross‑site scripting flaw that is triggered via the 'display_name' parameter. Because the plugin fails to perform proper input sanitization and does not escape the content when it is later rendered, an authenticated user who has a Subscriber role or higher can inject arbitrary JavaScript. When another user visits the community page and hovers over a comment’s like counter, the plugin’s tooltip handler assigns the attacker‑controlled value to the innerHTML of a tooltip element; the browser then parses the payload as live HTML and executes the embedded script. The flaw allows injection of code that will run in the victim’s browser context whenever the tooltip is triggered, giving the attacker the ability to run arbitrary JavaScript in that user’s session.

Affected Systems

The affected product is the SureDash – Community, Courses & Member Dashboard plugin from brainstormforce. All releases through and including software version 1.12.0 are vulnerable. Any WordPress site that has installed one of these versions and has users with a Subscriber‑level role or beyond can be exploited.

Risk and Exploitability

The CVSS score of 6.4 classifies the vulnerability as of moderate severity. The EPSS score of less than 1% indicates a very low probability that the flaw will be actively exploited at this time, and the vulnerability is not listed in the CISA KEV catalog. The attack requires an authenticated account with Subscriber rights or higher; no administrative privileges are necessary. Once an attacker injects malicious payloads, the effect is immediate for any user who triggers the tooltip by hovering over a comment, making the vulnerability straightforward to exploit by a legitimate authenticated user.

Generated by OpenCVE AI on October 16, 2026 at 16:12 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade SureDash to a version newer than 1.12.0 where the display_name parameter is properly sanitized and escaped.
  • If an upgrade cannot be performed promptly, temporarily deactivate the SureDash plugin to remove the vulnerable functionality until the patch is available.
  • Restrict the assignment of Subscriber or higher roles to trusted users to reduce the number of accounts that could inject malicious content.
  • Deploy a web application firewall or other filtering solution to block or sanitize the data‑tooltip‑description attribute and prevent user supplied content from being rendered as HTML.

Generated by OpenCVE AI on October 16, 2026 at 16:12 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 21 Oct 2026 20:45:00 +0000

Type Values Removed Values Added
First Time appeared Brainstorm Force
Brainstorm Force suredash
Brainstormforce
Brainstormforce suredash
Wordpress-extensions
Wordpress-extensions suredash
Vendors & Products Brainstorm Force
Brainstorm Force suredash
Brainstormforce
Brainstormforce suredash
Wordpress-extensions
Wordpress-extensions suredash

Fri, 16 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 16 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Description The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 1.12.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is triggered when any user hovers over a comment's like counter on a community page, as the plugin's tooltip handler assigns the attacker-controlled data-tooltip-description attribute value directly to innerHTML, re-parsing the browser-decoded entity payload as live HTML.
Title SureDash <= 1.12.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'display_name' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Brainstorm Force Suredash
Brainstormforce Suredash
Wordpress-extensions Suredash
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-16T14:14:58.815Z

Reserved: 2026-09-23T18:13:11.319Z

Link: CVE-2026-96870

cve-icon Vulnrichment

Updated: 2026-10-16T14:14:53.107Z

cve-icon NVD

Status : Deferred

Published: 2026-10-16T08:17:13.783

Modified: 2026-10-16T15:17:37.933

Link: CVE-2026-96870

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-21T20:22:40Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')