Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.
Published: 2026-10-26
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability allows stored cross‑site scripting due to improper neutralization of input during web page generation. An attacker who can supply malicious input that is stored by the Royal Elementor Addons plugin can later cause arbitrary script execution in the browsers of site visitors. This compromises confidentiality, integrity, and availability of the affected website and can be leveraged for phishing or hijacking user sessions.

Affected Systems

The issue affects the WordPress Royal Elementor Addons plugin from the earliest available version through 1.7.1069. Users of this plugin on any WordPress installation are vulnerable; the affected vendor is WProyal.

Risk and Exploitability

The CVSS score of 6.5 indicates a medium‑to‑high severity for executing arbitrary code on the client side. EPSS is not available, so the current estimate of exploitation probability is unknown. Since the vulnerability is not listed in CISA KEV, there is no known large‑scale exploitation at present. The likely attack vector is via the plugin’s administrative interface where users can submit content that is later displayed on public pages. An attacker who gains access to that interface or who can find a way to inject malicious content into the plugin’s data store can trigger the XSS.

Generated by OpenCVE AI on October 26, 2026 at 11:25 UTC.

Remediation

Vendor Solution

Update the WordPress Royal Elementor Addons plugin to the latest available version (at least 1.7.1070).


OpenCVE Recommended Actions

  • Update the WordPress Royal Elementor Addons plugin to version 1.7.1070 or later, as this applies the official fix.
  • If an immediate update is not possible, uninstall the Royal Elementor Addons plugin or disable it for public-facing pages to eliminate the stored payload vector.
  • Ensure any user‑generated content processed by the plugin is properly sanitized or filtered to prevent the execution of injected scripts.

Generated by OpenCVE AI on October 26, 2026 at 11:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.
Title WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T10:23:40.688Z

Reserved: 2026-09-24T10:23:10.130Z

Link: CVE-2026-97254

cve-icon Vulnrichment

Updated: 2026-10-26T10:14:49.647Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T10:16:53.657

Modified: 2026-10-26T11:16:39.147

Link: CVE-2026-97254

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T11:30:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')