Description
Unauthenticated Cross Site Scripting (XSS) in Premmerce Wishlist for WooCommerce <= 1.1.13 versions.
Published: 2026-10-01
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross-site scripting
Action: Upgrade Plugin
AI Analysis

Impact

The vulnerability is an unauthenticated Cross Site Scripting flaw that allows an attacker to inject arbitrary client‑side scripts into the wishlist pages of affected WordPress sites. By leveraging user‑controlled input fields that are not properly sanitized, a remote attacker can execute malicious JavaScript in the context of any visitor to the site, potentially leading to credential theft, session hijack, or malicious redirects. This weakness is classified as CWE‑79, a classic reflected XSS attack.

Affected Systems

The flaw affects the Premmerce Wishlist for WooCommerce plugin for WordPress, specifically all released versions up to and including 1.1.13. The latest patched release, 1.1.15, removes the vulnerability. Sites running earlier versions of the plugin should update promptly to avoid exploitation.

Risk and Exploitability

The CVSS base score of 7.1 indicates a medium vulnerability with potential confidentiality and integrity impact. Although the EPSS score is not available, the flaw is unauthenticated and can be triggered by any external actor, making it highly likely to be targeted. The vulnerability is not listed in the CISA KEV catalog, but its well‑known XSS nature and the lack of input validation make it a priority for rapid remediation.

Generated by OpenCVE AI on October 1, 2026 at 15:56 UTC.

Remediation

Vendor Solution

Update the WordPress Premmerce Wishlist for WooCommerce plugin to the latest available version (at least 1.1.15).


OpenCVE Recommended Actions

  • Upgrade Premmerce Wishlist for WooCommerce to version 1.1.15 or later.
  • Disable or remove any custom wishlist features that accept unsanitized user input or content.
  • Regularly scan the site for unexpected scripts and monitor user input for potential injection attacks.

Generated by OpenCVE AI on October 1, 2026 at 15:56 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 03 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 01 Oct 2026 20:00:00 +0000

Type Values Removed Values Added
First Time appeared Premmerce
Premmerce wishlist For Woocommerce
Wordpress-extensions
Wordpress-extensions premmerce Wishlist For Woocommerce
Vendors & Products Premmerce
Premmerce wishlist For Woocommerce
Wordpress-extensions
Wordpress-extensions premmerce Wishlist For Woocommerce

Thu, 01 Oct 2026 14:45:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Premmerce Wishlist for WooCommerce <= 1.1.13 versions.
Title WordPress Premmerce Wishlist for WooCommerce plugin <= 1.1.13 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Premmerce Wishlist For Woocommerce
Wordpress-extensions Premmerce Wishlist For Woocommerce
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-03T15:12:24.277Z

Reserved: 2026-09-24T10:23:19.165Z

Link: CVE-2026-97273

cve-icon Vulnrichment

Updated: 2026-10-03T15:11:28.479Z

cve-icon NVD

Status : Deferred

Published: 2026-10-01T15:17:38.247

Modified: 2026-10-03T16:16:48.590

Link: CVE-2026-97273

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-01T19:33:57Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')