Description
The Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR Compliance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Field via Regex-Mangled Output Buffer in all versions up to, and including, 1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the plugin's Remove mode to be active and the malicious comment to be published, either through auto-approval for known commenters or manual moderator approval.
Published: 2026-11-04
Score: 7.2 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Apply Update
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw in the Remove Google Fonts plugin for WordPress that allows attackers to embed malicious scripts into comment content that is rendered unsanitized. In affected versions up to 1.7, a malicious script can be injected into any published comment. Once a user visits a page that displays the compromised comment, the injected code runs in that user's browser, potentially allowing attackers to steal credentials, deface content or execute further attacks. The weakness originates from inappropriate input sanitization and output escaping, classified as CWE‑79.

Affected Systems

All versions of the plugin up to and including 1.7 are affected. The plugin, named Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR Compliance, is distributed by the easywpstuff feed and runs inside WordPress installations. Users of these WordPress sites that have installed this plugin are at risk.

Risk and Exploitability

The CVSS v3 score is 7.2, indicating a high severity cross‑site scripting vulnerability. No EPSS score is available, so the actual exploitation probability is unclear. The vulnerability is not listed in the CISA KEV catalog. Attackers need the plugin’s Remove mode to be active and comment publishing to be enabled, either through auto‑approval of known commenters or manual moderator approval. If those conditions are met, a non‑authenticated attacker can submit a comment containing a script, which will then be stored and later executed for any user who views the page that displays the comment.

Generated by OpenCVE AI on November 4, 2026 at 12:38 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the plugin to the latest version that fixes the issue; verify the current version is newer than 1.7.
  • If an update is not immediately possible, disable the plugin’s Remove mode or deactivate the plugin entirely to prevent the unsanitized comment output.
  • Ensure WordPress comment settings require manual moderation or restrict comment posting to trusted users, so that unauthenticated attackers cannot publish malicious content.

Generated by OpenCVE AI on November 4, 2026 at 12:38 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 04 Nov 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 04 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR Compliance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Field via Regex-Mangled Output Buffer in all versions up to, and including, 1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the plugin's Remove mode to be active and the malicious comment to be published, either through auto-approval for known commenters or manual moderator approval.
Title Remove Google Fonts <= 1.7 - Unauthenticated Stored Cross-Site Scripting via Comment Field via Regex-Mangled Output Buffer
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-04T15:18:54.742Z

Reserved: 2026-09-24T14:27:59.768Z

Link: CVE-2026-97397

cve-icon Vulnrichment

Updated: 2026-11-04T15:08:58.986Z

cve-icon NVD

Status : Deferred

Published: 2026-11-04T12:17:07.123

Modified: 2026-11-04T16:17:55.547

Link: CVE-2026-97397

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T12:45:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')