Description
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `givewp_campaign_grid` shortcode in versions up to, and including, 4.17.0 This is due to insufficient input sanitization and output escaping on user supplied shortcode attributes (`filter_by`, `layout`, `sort_by`, `order_by`) in the CampaignGridShortcode::parseAttributes() function combined with the render template emitting `json_encode($attributes)` inside a single-quoted HTML attribute without esc_attr() — json_encode() does not escape single quotes by default, so a `'` in an attribute value breaks out of the enclosing attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-10
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Apply Patch
AI Analysis

Impact

The givewp_campaign_grid shortcode in GiveWP versions up to and including 4.17.0 lacks proper input validation and output encoding for several user‑supplied attributes (filter_by, layout, sort_by, order_by). When an authenticated Contributor or higher creates a shortcode with malicious characters such as a single quote within the attribute values, the shortcode output embeds the attribute array via json_encode into a single‑quoted HTML attribute. Because json_encode does not escape single quotes, the attribute value can break out of its enclosing quote and inject arbitrary JavaScript. An attacker can therefore store malicious script code in the database that will execute whenever a visitor loads any page containing the affected shortcode, potentially enabling session hijacking, defacement, or other client‑side attacks.

Affected Systems

The vulnerability impacts WordPress sites running the GiveWP “Donation Plugin and Fundraising Platform” from the vendor stellarwp. All releases with the plugin version 4.17.0 or earlier are affected. The plugin in question is provided as a WordPress plugin and the issue is limited to the shortcode processing logic.

Risk and Exploitability

The CVSS score is 6.4, indicating moderate severity. An EPSS score is not available and the vulnerability is not listed in the CISA KEV catalogue. Exploitation requires the attacker to have Contributor‑level access or higher on the affected WordPress installation and the ability to add or modify shortcodes. Once a malicious shortcode is stored, the vulnerable script will run in the browsers of all users viewing the affected page, providing immediate cross‑site scripting capability. The threat vector is therefore local to the WordPress installation for authenticated users, but the impact is widespread for all site visitors.

Generated by OpenCVE AI on October 10, 2026 at 07:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the GiveWP plugin to version 4.18.0 or later, where the issue is fixed by proper sanitization and escaping of shortcode attributes.
  • Review existing pages and posts for any givewp_campaign_grid shortcodes containing unescaped or malicious attribute values and remove or sanitize them.
  • Restrict Contributor or lower role permissions if feasible, or enforce stricter content moderation to prevent creation of malicious shortcodes.

Generated by OpenCVE AI on October 10, 2026 at 07:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 23 Oct 2026 22:15:00 +0000

Type Values Removed Values Added
First Time appeared Stellarwp
Stellarwp givewp
Wordpress-extensions
Wordpress-extensions givewp
Vendors & Products Stellarwp
Stellarwp givewp
Wordpress-extensions
Wordpress-extensions givewp

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `givewp_campaign_grid` shortcode in versions up to, and including, 4.17.0 This is due to insufficient input sanitization and output escaping on user supplied shortcode attributes (`filter_by`, `layout`, `sort_by`, `order_by`) in the CampaignGridShortcode::parseAttributes() function combined with the render template emitting `json_encode($attributes)` inside a single-quoted HTML attribute without esc_attr() — json_encode() does not escape single quotes by default, so a `'` in an attribute value breaks out of the enclosing attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title GiveWP <= 4.17.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via givewp_campaign_grid Shortcode Attributes
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Stellarwp Givewp
Wordpress-extensions Givewp
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-11T12:23:57.247Z

Reserved: 2026-09-24T18:19:57.783Z

Link: CVE-2026-97643

cve-icon Vulnrichment

Updated: 2026-10-11T12:15:33.507Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T06:16:45.547

Modified: 2026-10-13T13:30:21.620

Link: CVE-2026-97643

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-23T22:00:23Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')