Description
YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution.

A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options.

A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.
Published: 2026-10-05
Score: 7.3 High
EPSS: < 1% Very Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable. Because the module imposes no restrictions on variable names, an attacker can target critical internal variables such as @INC or YAML's own load options. By setting $YAML::LoadCode or $YAML::UseCode to true, code loading is enabled for subsequent Load() calls, and a following perl/code document is executed through a string eval, which facilitates arbitrary Perl code execution in the same process.

Affected Systems

Perl module YAML is affected. Any installation of the YAML package with a version earlier than 1.27_001 is vulnerable. The issue is present in all prior releases; upgrading to 1.28 or later removes the ability to reinterpret package variables from loaded documents.

Risk and Exploitability

The CVSS score of 7.3 indicates high severity. The EPSS score of < 1% shows a very low exploitation probability. The vulnerability is not listed in KEV. Based on the description, it is inferred that the attacker must be able to submit two YAML documents to consecutive Load() calls within the same process. If an application accepts user‑supplied YAML, this can be carried out either locally or remotely, enabling an attacker to execute arbitrary Perl code and potentially compromise the host system or application.

Generated by OpenCVE AI on October 7, 2026 at 07:10 UTC.

Remediation

Vendor Solution

Upgrade to YAML 1.28 or later.


Vendor Workaround

For deployments that cannot upgrade to YAML 1.28, set $YAML::LoadBlessed = 0 before loading untrusted input. The option exists from YAML 1.25 and gates glob loading too.


OpenCVE Recommended Actions

  • Upgrade the YAML module to version 1.28 or newer, which removes the insecure variable assignment behavior.
  • If an upgrade is not immediately possible, set $YAML::LoadBlessed = 0 before any Load() calls that process untrusted data to block glob loading.
  • Ensure that $YAML::LoadCode and $YAML::UseCode remain disabled for all processes that load YAML, and audit any code paths that could inadvertently turn code loading on to mitigate the risk of accidental exploitation.

Generated by OpenCVE AI on October 7, 2026 at 07:10 UTC.

Tracking

Sign in to view the affected projects.

Advisories
Source ID Title
Ubuntu USN Ubuntu USN USN-8925-1 YAML-LibYAML vulnerabilities
History

Tue, 06 Oct 2026 21:30:00 +0000

Type Values Removed Values Added
First Time appeared Ingydotnet
Ingydotnet yaml
Vendors & Products Ingydotnet
Ingydotnet yaml

Tue, 06 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}

cvssV3_1

{'score': 7.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L'}


Mon, 05 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
References

Mon, 05 Oct 2026 12:15:00 +0000

Type Values Removed Values Added
References
Metrics threat_severity

None

cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}

threat_severity

Important


Mon, 05 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution. A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options. A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.
Title YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution
Weaknesses CWE-502
CWE-914
References

cve-icon MITRE

Status: PUBLISHED

Assigner: CPANSec

Published:

Updated: 2026-10-06T16:58:19.261Z

Reserved: 2026-09-21T21:17:21.642Z

Link: CVE-2019-25777

cve-icon Vulnrichment

Updated: 2026-10-06T16:58:01.220Z

cve-icon NVD

Status : Deferred

Published: 2026-10-05T07:16:29.557

Modified: 2026-10-06T17:17:09.893

Link: CVE-2019-25777

cve-icon Redhat

Severity : Important

Publid Date: 2026-10-05T06:50:17Z

Links: CVE-2019-25777 - Bugzilla

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T07:15:08Z

Weaknesses
  • CWE-502

    Deserialization of Untrusted Data

  • CWE-914

    Improper Control of Dynamically-Identified Variables