Description
IBM WebSphere Extreme Scale 8.6.1.0 through 8.6.2.2 could allow a remote attacker to bypass security restrictions due to improper Content Security Policy configuration.
Published: 2026-11-08
Score: 9.1 Critical
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting that enables remote script injection by exploiting an improper Content Security Policy in IBM WebSphere Extreme Scale
Action: Immediate Patch
AI Analysis

Impact

The flaw arises from an inadequate Content Security Policy configuration, which permits attackers to inject malicious scripts into the application. When the compromised page is rendered in a victim’s browser, the injected code executes with the privileges of the authenticated user, enabling the attacker to alter page behavior, exfiltrate data, or carry out other unauthorized actions within the application context.

Affected Systems

IBM WebSphere Extreme Scale 8.6.1.0 through 8.6.2.2 are affected. The issue is documented for both the 8.6.1.0 and 8.6.2.2 release lines.

Risk and Exploitability

The CVSS score of 9.1 indicates a high severity vulnerability. EPSS information is not available, and the flaw is not listed in the CISA KEV catalog. The likely attack vector is through the publicly exposed web interface, where a malicious user can supply crafted input that bypasses CSP enforcement and triggers XSS. Because the default configuration does not provide mitigations for this weakness, an attacker can potentially exploit the flaw without special conditions, leading to significant confidentiality, integrity, and availability risks.

Generated by OpenCVE AI on November 8, 2026 at 17:50 UTC.

Remediation

Vendor Solution

IBM strongly recommends addressing the vulnerability now. ProductVersion(s)APARRemediation/First FixIBM WebSphere eXtreme Scale8.6.1.0 - 8.6.2.2PH73641 For older versions, upgrade to latest fixpack 8.6.2.2 and then apply the PH73641 iFix. If you are using 8.6.2.2 directly apply the PH73641 iFix. Recommended Fixes page for WebSphere eXtreme Scale http://www.ibm.com/support/docview.wss


OpenCVE Recommended Actions

  • Apply the PH73641 iFix to every affected instance of IBM WebSphere Extreme Scale.
  • If the installation is beyond version 8.6.1.0 but older than 8.6.2.2, first upgrade to 8.6.2.2 and then apply the PH73641 iFix; if the system is already on 8.6.2.2, apply the iFix immediately.
  • Configure the application’s Content Security Policy to restrict permissible script sources and eliminate the conditions that enable XSS exploitation.

Generated by OpenCVE AI on November 8, 2026 at 17:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 16:15:00 +0000

Type Values Removed Values Added
Description IBM WebSphere Extreme Scale 8.6.1.0 through 8.6.2.2 could allow a remote attacker to bypass security restrictions due to improper Content Security Policy configuration.
Title IBM WebSphere eXtremes Scale Liberty deployment is affected by Cross Site Scripting(XSS) attacks.
First Time appeared Ibm
Ibm websphere Extreme Scale
Weaknesses CWE-16
CPEs cpe:2.3:a:ibm:websphere_extreme_scale:8.6.1.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:websphere_extreme_scale:8.6.2.2:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm websphere Extreme Scale
References
Metrics cvssV3_1

{'score': 9.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'}


Subscriptions

Ibm Websphere Extreme Scale
cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-08T16:08:41.893Z

Reserved: 2026-09-28T06:27:45.163Z

Link: CVE-2026-101117

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-08T16:16:36.103

Modified: 2026-11-08T16:16:36.223

Link: CVE-2026-101117

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T18:00:16Z

Weaknesses