Description
A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Published: 2026-10-04
Score: 6.9 Medium
EPSS: 79.2% High
KEV: Yes
Impact: Improper authentication allowing unauthorized access
Action: Patch
AI Analysis

Impact

The vulnerability resides in the checkSysPwd method of the ApiStructsAction component in Ahsay AhsayCBS. By manipulating the random argument, an attacker can bypass the authentication mechanism, enabling unauthorized calls to the system’s API endpoints. The flaw is exploitable remotely, and the exploit is now publicly known; attackers can gain unauthorized access to sensitive data or facilitate further attacks. The initial patch release did not fully address the issue, but subsequent releases include the proper fix.

Affected Systems

The vulnerability affects Ahsay AhsayCBS versions up to 9.15.2.69 and 10.3.4.44. Updating to version 9.15.2.70 or 10.3.4.45 removes the flaw.

Risk and Exploitability

The CVSS score of 6.9 indicates moderate severity, and the vulnerability is exploitable remotely. The EPSS score of 79% signifies a high likelihood that the flaw will be exploited. The exploit is public and the vulnerability is listed in the CISA KEV catalog, indicating that attackers are actively targeting it. Attackers can trigger the flaw by manipulating the random argument, bypassing authentication checks and impersonating legitimate users without valid credentials. This can lead to unauthorized access to API endpoints and potential exposure of sensitive data or the ability to launch further attacks.

Generated by OpenCVE AI on October 26, 2026 at 16:32 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to Ahsay CBS 9.15.2.70 or 10.3.4.45 or later to remove the vulnerable code.
  • If an update cannot be applied immediately, restrict access to the affected API endpoints using firewall rules or network segmentation, allowing only trusted IP ranges to interact with the service.
  • Enable detailed authentication logs and monitor for attempts that manipulate the random argument or show unauthorized access, reporting any suspicious behavior to the security team.

Generated by OpenCVE AI on October 26, 2026 at 16:32 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 15:30:00 +0000


Mon, 26 Oct 2026 15:00:00 +0000

Type Values Removed Values Added
Description A vulnerability was detected in Ahsay AhsayCBS up to 10.3.2. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 10.3.4 is able to mitigate this issue. It is recommended to upgrade the affected component. A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
References
Metrics cvssV2_0

{'score': 7.5, 'vector': 'AV:N/AC:L/Au:N/C:P/I:P/A:P/E:POC/RL:OF/RC:C'}

cvssV3_0

{'score': 7.3, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C'}

cvssV3_1

{'score': 7.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P'}

cvssV2_0

{'score': 7.5, 'vector': 'AV:N/AC:L/Au:N/C:P/I:P/A:P/E:H/RL:OF/RC:C'}

cvssV3_0

{'score': 7.3, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:H/RL:O/RC:C'}

cvssV3_1

{'score': 7.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:H/RL:O/RC:C'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:A'}


Thu, 15 Oct 2026 14:00:00 +0000

Type Values Removed Values Added
First Time appeared Ahsay cloud Backup Suite
CPEs cpe:2.3:a:ahsay:cloud_backup_suite:*:*:*:*:*:*:*:*
Vendors & Products Ahsay cloud Backup Suite

Wed, 14 Oct 2026 20:30:00 +0000

Type Values Removed Values Added
References
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'active', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 19:45:00 +0000

Type Values Removed Values Added
Metrics kev

{'dateAdded': '2026-10-14T00:00:00+00:00', 'dueDate': '2026-10-17T00:00:00+00:00'}


Mon, 05 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sun, 04 Oct 2026 06:45:00 +0000

Type Values Removed Values Added
Description A vulnerability was detected in Ahsay AhsayCBS up to 10.3.2. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 10.3.4 is able to mitigate this issue. It is recommended to upgrade the affected component.
Title Ahsay AhsayCBS API ApiStructsAction.java checkSysPwd improper authentication
First Time appeared Ahsay
Ahsay ahsaycbs
Weaknesses CWE-287
CPEs cpe:2.3:a:ahsay:ahsaycbs:*:*:*:*:*:*:*:*
Vendors & Products Ahsay
Ahsay ahsaycbs
References
Metrics cvssV2_0

{'score': 7.5, 'vector': 'AV:N/AC:L/Au:N/C:P/I:P/A:P/E:POC/RL:OF/RC:C'}

cvssV3_0

{'score': 7.3, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C'}

cvssV3_1

{'score': 7.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P'}


Subscriptions

Ahsay Ahsaycbs Cloud Backup Suite
cve-icon MITRE

Status: PUBLISHED

Assigner: VulDB

Published:

Updated: 2026-10-26T14:31:10.237Z

Reserved: 2026-10-03T13:13:31.953Z

Link: CVE-2026-105133

cve-icon Vulnrichment

Updated: 2026-10-05T15:26:46.330Z

cve-icon NVD

Status : Analyzed

Published: 2026-10-04T07:16:33.087

Modified: 2026-10-26T18:07:09.000

Link: CVE-2026-105133

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T16:45:14Z

Weaknesses