Description
The Productive Commerce WordPress plugin before 1.1.54 does not sanitise and escape a parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection attacks.
Published: 2026-11-08
Score: n/a
EPSS: n/a
KEV: No
Impact: Unauthenticated SQL injection allowing database compromise
Action: Apply Patch
AI Analysis

Impact

The Productive Commerce WordPress plugin before version 1.1.54 fails to sanitize and escape a user-supplied parameter that is incorporated directly into an SQL statement. This flaw permits an unauthenticated actor to inject arbitrary SQL code, potentially enabling data exfiltration, modification, or other destructive database operations. The weakness is a classic input validation flaw, identified as CWE-89, and can affect the confidentiality, integrity, and availability of the underlying database used by the WordPress site.

Affected Systems

The vulnerability applies to WordPress sites that use the Productive Commerce plugin in any release earlier than 1.1.54. No specific sub‑versions beyond that threshold are listed, so all older deployments are potentially impacted while versions 1.1.54 and newer are considered safe.

Risk and Exploitability

The CVSS score for this issue is not disclosed, and the EPSS value is unavailable, so the precise probability and severity are unknown. However, the vulnerability is publicly identified and requires no authentication, implying a high attack surface via the web interface. Because it is not listed in CISA's KEV, there is no current evidence of widespread exploitation, but the absence of a CVSS score suggests that the vendor has not released an official quantification. The theoretical likelihood of exploitation remains significant due to the ease of constructing an injec­tive payload in a web context.

Generated by OpenCVE AI on November 8, 2026 at 07:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Productive Commerce plugin to version 1.1.54 or later to eliminate the SQL injection vector.
  • If an immediate upgrade is not possible, restrict access to the Wishlist and Compare handlers to authenticated users or limit traffic by IP to mitigate exposure.
  • Apply application‑level input validation and proper escaping for any parameters that are later used in SQL queries, in accordance with CWE‑89 guidelines.

Generated by OpenCVE AI on November 8, 2026 at 07:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-89

Sun, 08 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Productive Commerce WordPress plugin before 1.1.54 does not sanitise and escape a parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection attacks.
Title Productive Commerce < 1.1.54 - Unauthenticated SQLi via Wishlist and Compare Handlers
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-08T06:00:30.904Z

Reserved: 2026-10-13T10:19:00.910Z

Link: CVE-2026-109925

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-08T06:17:04.443

Modified: 2026-11-08T06:17:04.443

Link: CVE-2026-109925

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T07:30:11Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')