Description
Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Published: 2026-10-15
Score: 5.3 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Privilege Escalation
Action: Patch Now
AI Analysis

Impact

The APIExperts Square for WooCommerce plugin (woosquare) suffers from a missing authorization check, enabling users to perform actions that should be restricted to privileged administrators. This broken access control flaw can allow attackers to view or manipulate sensitive e‑commerce data, such as orders or payment details, thereby compromising confidentiality and integrity. The vulnerability aligns with CWE‑862, an improper authorization weakness.

Affected Systems

WordPress plugin "APIExperts Square for WooCommerce" supplied by WPExperts, affecting all releases up to and including version 4.7.5. The issue is present in any installation of the plugin before the 4.7.6 release.

Risk and Exploitability

The CVSS score of 5.3 indicates moderate severity, while the EPSS of less than 1% suggests a low probability of exploitation observed in the wild. The flaw is not listed in the CISA KEV catalog. An attacker could exploit the vulnerability by sending crafted requests to exposed plugin API endpoints over the public internet, potentially without needing initial authentication. The impact could elevate a regular user to administrative privileges or allow unauthorized manipulation of e‑commerce transactions.

Generated by OpenCVE AI on October 16, 2026 at 17:51 UTC.

Remediation

Vendor Solution

Update the WordPress APIExperts Square for WooCommerce plugin to the latest available version (at least 4.7.6).


OpenCVE Recommended Actions

  • Apply the latest plugin update (version 4.7.6 or later) to eliminate the broken access control.
  • Ensure that WordPress core and WooCommerce are also updated to their latest stable releases to provide complementary security controls.
  • Restrict the plugin’s administrative and API endpoints to authenticated administrator roles only, using WordPress user role settings or server‑level access controls such as .htaccess.

Generated by OpenCVE AI on October 16, 2026 at 17:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 18:00:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Title WordPress APIExperts Square for WooCommerce plugin <= 4.7.5 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-15T18:24:51.313Z

Reserved: 2026-10-14T00:22:17.448Z

Link: CVE-2026-110367

cve-icon Vulnrichment

Updated: 2026-10-15T18:24:46.274Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T18:17:25.743

Modified: 2026-10-15T19:56:13.350

Link: CVE-2026-110367

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T18:00:16Z

Weaknesses