Description
Netgate pfSense CE through 2.9.0 contains a newline injection vulnerability in services_pppoe_edit.php that allows privileged users to inject mpd.secret entries via unvalidated username POST fields. Attackers with the PPPoE Server Edit privilege can add a line whose secret begins with '!', making mpd5 run commands as root when a PPPoE client authenticates.
Published: 2026-10-15
Score: 7.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Command Injection leading to arbitrary root execution on PPPoE client authentication
Action: Apply patch
AI Analysis

Impact

A newline injection flaw in the services_pppoe_edit.php file allows users with PPPoE Server Edit privilege to inject entries into mpd.secret by providing a specially crafted username POST field. When the injected secret line begins with the character '!', the mpd5 daemon interprets it as a command and executes it with root privileges during PPPoE client authentication. The vulnerability is a classic CWE-93 command injection that enables privileged command execution.

Affected Systems

Netgate pfSense Community Edition versions up to and including 2.9.0 are affected. The flaw resides in the PPPoE server configuration editor and requires the user to possess edit permissions for PPPoE servers.

Risk and Exploitability

The CVSS score of 7.5 classifies the issue as high severity. While the EPSS score is not available, the vulnerability is not currently listed in the CISA KEV catalog, indicating no known widespread exploitation yet. However, because the attack requires PPPoE Server Edit rights, it can only be triggered by a privileged local user, but the consequence is full root access to the system when a PPPoE client connects. The risk is significant for any environment where untrusted users could acquire such privileges or where PPPoE services are exposed to untrusted clients.

Generated by OpenCVE AI on October 16, 2026 at 17:26 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to the latest pfSense Community Edition release that includes the fix for the services_pppoe_edit.php newline injection flaw
  • Restrict the PPPoE Server Edit privilege to a minimal set of trusted administrators and audit existing PPPoE configurations for potential malicious entries
  • Temporarily disable or remove any configuration that allows usernames to be set with a leading '!' in the PPPoE server settings to prevent mpd.secret exploitation

Generated by OpenCVE AI on October 16, 2026 at 17:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 20 Oct 2026 15:45:00 +0000

Type Values Removed Values Added
First Time appeared Pfsense
Pfsense pfsense
CPEs cpe:2.3:a:pfsense:pfsense:*:*:*:*:community:*:*:*
Vendors & Products Pfsense
Pfsense pfsense

Fri, 16 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'poc', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 19:00:00 +0000

Type Values Removed Values Added
Description Netgate pfSense CE through 2.9.0 contains a newline injection vulnerability in services_pppoe_edit.php that allows privileged users to inject mpd.secret entries via unvalidated username POST fields. Attackers with the PPPoE Server Edit privilege can add a line whose secret begins with '!', making mpd5 run commands as root when a PPPoE client authenticates.
Title Netgate pfSense CE through 2.9.0 Command Injection via PPPoE Server Username
First Time appeared Netgate
Netgate pfsense
Weaknesses CWE-93
CPEs cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*
Vendors & Products Netgate
Netgate pfsense
References
Metrics cvssV3_1

{'score': 6.6, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H'}

cvssV4_0

{'score': 7.5, 'vector': 'CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-16T17:11:33.240Z

Reserved: 2026-10-15T18:21:19.617Z

Link: CVE-2026-111219

cve-icon Vulnrichment

Updated: 2026-10-16T16:29:14.891Z

cve-icon NVD

Status : Analyzed

Published: 2026-10-15T19:17:34.357

Modified: 2026-10-20T15:37:57.990

Link: CVE-2026-111219

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-24T22:15:01Z

Weaknesses
  • CWE-93

    Improper Neutralization of CRLF Sequences ('CRLF Injection')