Impact
EPICS Base 7.0.10 and earlier contain an integer overflow during message length validation in protocol parsing. This flaw can lead to an out‑of‑bounds memory write. An attacker exploiting the vulnerability can force the EPICS process to crash or become unstable, effectively denying service to clients that rely on the control system.
Affected Systems
The vulnerability affects EPICS Base on versions 7.0.10 and earlier. All installations running EPICS Base prior to version 7.0.11 are exposed. Users should upgrade to 7.0.11, which contains the fix for the integer overflow.
Risk and Exploitability
The CVSS score is 8.8, indicating a high severity exploit. EPSS data are not available, and the vulnerability is not currently listed in CISA's KEV catalog. The flaw can be triggered by malformed protocol messages, which are typically sent over network connections. Therefore, the most likely attack vector is remote, through an application or network interface that accepts EPICS protocol data. Exploitation would require an attacker to successfully send a crafted payload to the EPICS Base process, causing a buffer overrun that destabilizes the service.
OpenCVE Enrichment