Description
SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5DoSecureDelete() that allows attackers to write past the leaf page buffer via crafted footer key offsets. Attackers can supply a database file with a corrupted FTS5 index that, when deleted from with secure-delete enabled, corrupts heap memory and crashes the application.
Published: 2026-10-30
Score: 8.5 High
EPSS: n/a
KEV: No
Impact: Heap Buffer Overflow leading to memory corruption and crash
Action: Upgrade
AI Analysis

Impact

SQLite versions prior to 3.54.0 contain a heap buffer overflow in the fts5DoSecureDelete() function of the FTS5 extension. The flaw occurs when crafted footer key offsets allow an attacker to write beyond the leaf page buffer, corrupting heap memory. This can lead to application crashes and potential data loss, but the description does not indicate arbitrary code execution. The weakness is classified as CWE-787.

Affected Systems

The vulnerability affects all installations of SQLite that include the FTS5 extension and are built with a version earlier than 3.54.0. This includes the standard SQLite library distributed for many platforms, regardless of operating system, identified by the CPE cpe:2.3:a:sqlite:sqlite:*:*:*:*:*:*:*:*. The product name is SQLite.

Risk and Exploitability

The CVSS score of 8.5 indicates a high severity risk. The EPSS score is not available and the vulnerability is not listed in the CISA KEV catalog, suggesting no known public exploits at this time. The attack requires the ability to supply a maliciously crafted database file to an application that uses SQLite with secure-delete enabled for FTS5. It is likely to be a local attack vector if the application manipulates untrusted or externally-provided database files, or an indirect remote vector if an attacker can influence a database file used by the system.

Generated by OpenCVE AI on October 30, 2026 at 12:27 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to SQLite 3.54.0 or later, which contains the fts5DoSecureDelete() fix.
  • If an upgrade cannot be done immediately, disable the secure-delete option for FTS5 in all affected SQLite installations.
  • Implement validation or sanitization of database files before loading them into the application to detect corrupted FTS5 indexes.

Generated by OpenCVE AI on October 30, 2026 at 12:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 11:45:00 +0000

Type Values Removed Values Added
Description SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5DoSecureDelete() that allows attackers to write past the leaf page buffer via crafted footer key offsets. Attackers can supply a database file with a corrupted FTS5 index that, when deleted from with secure-delete enabled, corrupts heap memory and crashes the application.
Title SQLite before 3.54.0 Heap Buffer Overflow via FTS5 fts5DoSecureDelete()
First Time appeared Sqlite
Sqlite sqlite
Weaknesses CWE-787
CPEs cpe:2.3:a:sqlite:sqlite:*:*:*:*:*:*:*:*
Vendors & Products Sqlite
Sqlite sqlite
References
Metrics cvssV3_1

{'score': 7.8, 'vector': 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'}

cvssV4_0

{'score': 8.5, 'vector': 'CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-30T11:30:39.834Z

Reserved: 2026-10-30T00:39:33.151Z

Link: CVE-2026-119374

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T12:16:36.187

Modified: 2026-10-30T12:16:36.187

Link: CVE-2026-119374

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T13:00:14Z

Weaknesses