Description
Missing Authorization vulnerability in LeapWorx Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through 2.3.18.
Published: 2026-11-07
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Broken Access Control
Action: Patch Update
AI Analysis

Impact

The vulnerability is a missing authorization flaw in the LeapWorx Premium Blocks – Gutenberg Blocks for WordPress plugin that allows attackers to exploit incorrectly configured access control settings, classified as CWE‑862, which can enable unauthorized users to gain elevated access to the plugin’s features and potentially compromise the website’s integrity and expose sensitive data.

Affected Systems

LeapWorx’s Premium Blocks – Gutenberg Blocks for WordPress plugin is affected on all versions from the initial release up to and including 2.3.18; any WordPress site running any of those plugin versions is at risk.

Risk and Exploitability

The CVSS score of 5.3 indicates a medium severity, with no publicly reported exploits yet (EPSS not available) and it is not listed in the CISA KEV catalog, implying no confirmed widespread exploitation. The likely attack vector is a user with access to the WordPress administration area who can interact with the plugin, as the flaw arises from misconfigured permissions; an attacker could exploit this to bypass intended restrictions and gain unauthorized actions within the plugin.

Generated by OpenCVE AI on November 7, 2026 at 10:37 UTC.

Remediation

Vendor Solution

Update the WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin to the latest available version (at least 2.3.19).


OpenCVE Recommended Actions

  • Upgrade the WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin to version 2.3.19 or newer.
  • Review the plugin's access control settings to ensure they enforce the intended restrictions.
  • Audit site user roles and permissions to identify and remove any unnecessary elevated privileges.

Generated by OpenCVE AI on November 7, 2026 at 10:37 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 09:30:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in LeapWorx Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through 2.3.18.
Title WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin <= 2.3.18 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T09:09:22.318Z

Reserved: 2026-11-06T00:25:34.012Z

Link: CVE-2026-123466

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T10:17:11.773

Modified: 2026-11-07T10:17:11.910

Link: CVE-2026-123466

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T10:45:09Z

Weaknesses