Description
Missing Authorization vulnerability in HivePress HivePress hivepress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects HivePress: from n/a through 1.8.1.
Published: 2026-11-07
Score: 4.3 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized Access
Action: Patch Immediately
AI Analysis

Impact

The HivePress plugin suffers a missing authorization flaw that allows attackers to bypass intended access controls and potentially manipulate data or display content that should be restricted. This vulnerability arises from incorrectly configured security levels, enabling unauthorized actions that exceed the privileges of the current user.

Affected Systems

The flaw impacts HivePress versions up to 1.8.1 inclusive, as used in WordPress installations that have not yet applied the 1.8.2 update. Any WordPress site running the affected HivePress plugin is vulnerable regardless of the WordPress core version.

Risk and Exploitability

With a CVSS score of 4.3, the flaw presents moderate risk, and its exploitation probability is currently unknown due to the absence of an EPSS score. The version is not listed in CISA’s KEV, suggesting no widespread exploit activity has been observed. The likely attack vector involves interacting with plugin configuration pages or endpoints that lack proper authorization checks, potentially accessible to unauthenticated or low‑privileged users.

Generated by OpenCVE AI on November 7, 2026 at 11:20 UTC.

Remediation

Vendor Solution

Update the WordPress HivePress plugin to the latest available version (at least 1.8.2).


OpenCVE Recommended Actions

  • Update the HivePress plugin to version 1.8.2 or later
  • Verify that the plugin’s configuration defaults protect sensitive endpoints (e.g., check for default admin credentials or role restrictions)
  • Re‑validate role‑based access controls and ensure that only users with appropriate permissions can access critical plugin functionality

Generated by OpenCVE AI on November 7, 2026 at 11:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 10:45:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in HivePress HivePress hivepress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects HivePress: from n/a through 1.8.1.
Title WordPress HivePress plugin <= 1.8.1 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 4.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T10:42:59.418Z

Reserved: 2026-11-06T00:25:34.012Z

Link: CVE-2026-123470

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T11:17:01.120

Modified: 2026-11-07T11:17:01.240

Link: CVE-2026-123470

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:30:13Z

Weaknesses