Description
Missing Authorization vulnerability in LeapWorx Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through 2.3.18.
Published: 2026-11-07
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized Access
Action: Patch
AI Analysis

Impact

The vulnerability is a missing authorization flaw in the Premium Blocks – Gutenberg Blocks for WordPress plugin that lets a user perform actions or access features beyond their intended permission level. Exploiting this flaw can allow an attacker to manipulate block settings, upload or edit content, or otherwise use the plugin’s features without proper authentication checks, compromising the integrity of site content. The weakness is classified as CWE‑862, indicating a security flaw where the system fails to check access rights before allowing operations.

Affected Systems

Vulnerable versions of the LeapWorx plugin are those up to and including 2.3.18. Any WordPress installation that has Premium Blocks – Gutenberg Blocks for WordPress version 2.3.18 or older is potentially impacted and should review the installed plugin version and upgrade accordingly.

Risk and Exploitability

The CVSS score of 5.3 rates this as a moderate severity issue, and the lack of an EPSS score indicates no publicly known exploitation statistics are available. The vulnerability is not listed in the CISA KEV catalog, suggesting it is not publicly exploited at large scale. The most likely attack vector is via authenticated access to the plugin’s administrative interface, but it could also be traversed by unauthenticated users if the plugin exposes any endpoints. The risk to systems is an unauthorized escalation of privileges that can lead to content tampering or data leakage.

Generated by OpenCVE AI on November 7, 2026 at 13:22 UTC.

Remediation

Vendor Solution

Update the WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin to the latest available version (at least 2.3.19).


OpenCVE Recommended Actions

  • Update the Premium Blocks – Gutenberg Blocks for WordPress plugin to version 2.3.19 or later
  • Re‑audit user roles and capabilities that interact with the plugin to ensure they only have the permissions required for their duties
  • Verify that any REST API or Ajax endpoints provided by the plugin enforce proper authorization checks

Generated by OpenCVE AI on November 7, 2026 at 13:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 12:45:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in LeapWorx Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through 2.3.18.
Title WordPress Premium Blocks – Gutenberg Blocks for WordPress plugin <= 2.3.18 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T12:36:48.283Z

Reserved: 2026-11-06T00:25:34.012Z

Link: CVE-2026-123474

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T13:16:37.267

Modified: 2026-11-07T13:16:37.383

Link: CVE-2026-123474

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T13:30:12Z

Weaknesses