Description
The WooCommerce Bookings WordPress plugin before 3.11.0 does not limit a user-supplied value before using it to allocate memory in one of its unauthenticated AJAX actions, allowing unauthenticated attackers to exhaust server memory and cause a Denial of Service with a single request.
Published: 2026-10-11
Score: 7.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Denial of Service
Action: Patch Immediately
AI Analysis

Impact

The WooCommerce Bookings WordPress plugin before version 3.11.0 allows attackers to supply an arbitrary size value in one of its unauthenticated AJAX actions without validation, causing the plugin to allocate that amount of memory. This uncontrolled allocation can exhaust the server’s RAM, leading to a denial of service with a single crafted request. The flaw reflects input validation failures that enable uncontrolled resource consumption (CWE‑400) and directly impacts the availability of affected WordPress sites.

Affected Systems

Every deployment of WooCommerce Bookings prior to version 3.11.0 across all WordPress websites is vulnerable, regardless of the specific WordPress version or hosting configuration.

Risk and Exploitability

The vulnerability’s lack of authentication requirements combined with the ability to cause memory exhaustion produces a severe availability impact. The EPSS score is <1% (approximately 0.0016), indicating a low to moderate probability of exploitation, but the simplicity of the exploit and absence of defensive controls suggest a high likelihood of exploitation in a targeted or opportunistic scenario. The CVSS score is 7.5, indicating substantial potential for service disruption. The vulnerability is not listed in the CISA KEV catalog.

Generated by OpenCVE AI on October 11, 2026 at 17:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the WooCommerce Bookings plugin to version 3.11.0 or later, which removes the unsanitized memory‑allocation path.
  • If an immediate upgrade is not feasible, disable the affected AJAX endpoint by removing the corresponding action hook or configuring the plugin to allow the endpoint only for authenticated administrators.
  • Implement server‑level limits such as adjusting PHP’s memory_limit and using application firewall rules to throttle or block unusually large AJAX requests.
  • Monitor memory usage on the server and configure alerts to detect abnormal usage spikes that could indicate exploitation attempts.

Generated by OpenCVE AI on October 11, 2026 at 17:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-770

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-400
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sun, 11 Oct 2026 08:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-770

Sun, 11 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The WooCommerce Bookings WordPress plugin before 3.11.0 does not limit a user-supplied value before using it to allocate memory in one of its unauthenticated AJAX actions, allowing unauthenticated attackers to exhaust server memory and cause a Denial of Service with a single request.
Title WooCommerce Bookings < 3.11.0 - Unauthenticated Denial of Service
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-11T11:32:46.642Z

Reserved: 2026-07-06T11:54:59.754Z

Link: CVE-2026-14854

cve-icon Vulnrichment

Updated: 2026-10-11T11:28:18.875Z

cve-icon NVD

Status : Deferred

Published: 2026-10-11T07:17:24.003

Modified: 2026-10-13T20:36:00.850

Link: CVE-2026-14854

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-11T17:30:17Z

Weaknesses
  • CWE-400

    Uncontrolled Resource Consumption