Impact
The vulnerability is a DOM‑Based Cross‑Site Scripting flaw in the WordPress Popup Maker plugin through version 1.23.0. Improper neutralization of input during web page generation allows an attacker to inject malicious JavaScript that executes in the browsers of any user who views a popup. The flaw, classified as CWE‑79, allows arbitrary script execution in the victim’s browser.
Affected Systems
The vulnerability affects the WordPress Popup Maker plugin developed by Code Atlantic LLC, specifically all releases up to and including 1.23.0. Users who have installed older versions should upgrade to version 1.24.0 or later to remediate the flaw.
Risk and Exploitability
The CVSS score of 7.1 indicates a moderate to high risk level, yet the EPSS score is < 1%. The vulnerability is not listed in the CISA KEV catalog. An attacker who crafts malicious popup content can cause scripts to execute in the browser of anyone who views the popup.
OpenCVE Enrichment