Description
Out-of-bounds Write vulnerability in Apache HTTP Server's mod_charset_lite.



This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Published: 2026-10-01
Score: 7.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

This vulnerability is an out‑of‑bounds write in the finish_partial_char function of the mod_charset_lite module. The flaw allows a malformed HTTP request to corrupt the heap memory that the module uses to convert character sets. If an attacker succeeds, they could replace or corrupt memory, leading to potential arbitrary code execution or a crash that disrupts service.

Affected Systems

The flaw exists in Apache HTTP Server 2.4.0 through 2.4.68, released by the Apache Software Foundation. Any installation of Apache HTTP Server in that version range that has mod_charset_lite enabled— which is default in most builds— is vulnerable.

Risk and Exploitability

The CVSS score is 7.5, indicating high risk. EPSS is not available and the vulnerability is not listed in the CISA KEV catalog. The likely attack vector is remote, since the mod_charset_lite module parses data from HTTP requests. An attacker can trigger the exploit by sending a specially crafted request that causes an out‑of‑bounds write, potentially leading to arbitrary code execution. No specific authentication or privilege escalation requirements are listed, implying that a publicly reachable server could be targeted.

Generated by OpenCVE AI on October 1, 2026 at 20:53 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Apache HTTP Server to version 2.4.69 or later, which removes the vulnerability.
  • If an immediate upgrade is not possible, disable the mod_charset_lite module or restrict its use to trusted requests to reduce risk.
  • Apply general best practices such as restricting request sizes, monitoring logs for suspicious activity, and using firewalls to block anomalous traffic.

Generated by OpenCVE AI on October 1, 2026 at 20:53 UTC.

Tracking

Sign in to view the affected projects.

Advisories
Source ID Title
Debian DSA Debian DSA DSA-6569-1 apache2 security update
History

Fri, 02 Oct 2026 21:00:00 +0000

Type Values Removed Values Added
CPEs cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Fri, 02 Oct 2026 12:15:00 +0000

Type Values Removed Values Added
First Time appeared Redhat
Redhat hummingbird
CPEs cpe:/a:redhat:hummingbird:1
Vendors & Products Redhat
Redhat hummingbird
References
Metrics threat_severity

None

threat_severity

Important


Fri, 02 Oct 2026 01:15:00 +0000

Type Values Removed Values Added
First Time appeared Apache
Apache http Server
Vendors & Products Apache
Apache http Server

Thu, 01 Oct 2026 21:30:00 +0000

Type Values Removed Values Added
References

Thu, 01 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 01 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Description Out-of-bounds Write vulnerability in Apache HTTP Server's mod_charset_lite. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Title Apache HTTP Server: mod_charset_lite: Heap overflow in finish_partial_char
Weaknesses CWE-787
References

Subscriptions

Apache Http Server
Redhat Hummingbird
cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-10-01T20:09:22.770Z

Reserved: 2026-06-19T12:17:10.922Z

Link: CVE-2026-56153

cve-icon Vulnrichment

Updated: 2026-10-01T20:09:22.770Z

cve-icon NVD

Status : Analyzed

Published: 2026-10-01T17:17:26.487

Modified: 2026-10-02T20:53:53.630

Link: CVE-2026-56153

cve-icon Redhat

Severity : Important

Publid Date: 2026-10-01T16:03:25Z

Links: CVE-2026-56153 - Bugzilla

cve-icon OpenCVE Enrichment

Updated: 2026-10-02T01:00:17Z

Weaknesses