Impact
The certifier plugin in Apache Traffic Server builds SSL certificates using the SNI value supplied by the client. Because the SNI is not validated, an attacker can cause the server to generate a certificate for any arbitrary domain name. Based on the description, it is inferred that these forged certificates could be used to impersonate the alleged domain, potentially allowing man‑in‑the‑middle attacks.
Affected Systems
Apache Traffic Server versions 8.0.0 through 8.1.11, 9.0.0 through 9.2.14, and 10.0.0 through 10.1.3 are affected. The vendor recommends upgrading to at least 9.2.15 or 10.1.4 to address the issue.
Risk and Exploitability
The vulnerability carries a CVSS score of 8.4, indicating a high severity. The EPSS score is less than 1 %, pointing to a low likelihood of exploitation at the time of assessment, and the flaw is not listed in the CISA KEV catalog. An attacker can trigger the issue remotely by supplying a malicious SNI in an HTTPS request; no local code execution is required after the patch is applied.
OpenCVE Enrichment