Description
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Published: 2026-08-18
Score: 8.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Arbitrary File Write
Action: Patch Immediately
AI Analysis

Impact

The flaw is an argument injection in CodeWhale's git_show utility. The model supplied rev value is forwarded to the git command without validation or an end‑of‑options sentinel, so a string beginning with --output= is treated as an option by git. Because the tool is presented as read‑only and automatically trusted, an attacker can influence the rev value via a malicious CodeWhale repository combined with prompt injection. This can lead to unprompted arbitrary writes at the privilege of the user running CodeWhale, such as to ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig.

Affected Systems

Versions from CodeWhale 0.3.27 through 0.8.63 are affected. The vulnerable components are the codewhale, codewhale‑tui, and deepseek‑tui packages distributed on npm, crates.io, and GitHub. The default affected editions include deepseek‑tui >= 0.3.27 and < 0.8.41, and codewhale / codewhale‑tui >= 0.8.41 and < 0.8.64.

Risk and Exploitability

The CVSS score of 8.5 indicates high severity, but the EPSS score of < 1% shows that exploitation is expected to be rare. The vulnerability is not listed in CISA’s KEV catalog. Exploitation requires the attacker to supply a crafted rev string, which is only possible if the git_show command is executed with untrusted input from a repository that the user trusts. The lack of an end‑of‑options sentinel and the ability to write arbitrary files poses a significant risk if the conditions are met, but the low EPSS score suggests a low probability of widespread attacks at present.

Generated by OpenCVE AI on October 29, 2026 at 23:55 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade CodeWhale to version 0.8.64 or later, which validates the rev parameter.
  • If an upgrade is not yet possible, limit the execution of git_show to trusted repositories or disable its auto‑approved status.
  • Remove or neutralize the auto‑approved flag for git_show until a fix is in place.

Generated by OpenCVE AI on October 29, 2026 at 23:55 UTC.

Tracking

Sign in to view the affected projects.

Advisories
Source ID Title
Github GHSA Github GHSA GHSA-7j5w-7r7x-9v27 CodeWhale: Argument Injection in `git_show` Tool Allows Arbitrary File Write Without Approval
History

Thu, 29 Oct 2026 20:30:00 +0000

Type Values Removed Values Added
Description CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in 0.8.64 by adding rev validation. CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

Tue, 18 Aug 2026 17:45:00 +0000

Type Values Removed Values Added
First Time appeared Hmbown
Hmbown codewhale
Vendors & Products Hmbown
Hmbown codewhale

Tue, 18 Aug 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'poc', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Tue, 18 Aug 2026 15:30:00 +0000

Type Values Removed Values Added
Description CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in 0.8.64 by adding rev validation.
Title CodeWhale before 0.8.64 Argument Injection via git_show
Weaknesses CWE-73
References
Metrics cvssV3_1

{'score': 9.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:H'}

cvssV4_0

{'score': 8.5, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H'}


Subscriptions

Hmbown Codewhale
cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-29T21:16:54.792Z

Reserved: 2026-08-18T15:05:54.225Z

Link: CVE-2026-75913

cve-icon Vulnrichment

Updated: 2026-08-18T15:56:52.195Z

cve-icon NVD

Status : Deferred

Published: 2026-08-18T16:18:23.363

Modified: 2026-10-29T21:17:33.277

Link: CVE-2026-75913

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T00:00:06Z

Weaknesses
  • CWE-73

    External Control of File Name or Path