Description
An unchecked memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 on allows a crafted PDF to execute an out-of-bounds memory write. This could crash the program or cause memory corruption.
Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Published: 2026-11-04
Score: n/a
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

Apache OpenOffice versions through 4.1.16 contain an unchecked memory access in the PDF import module that allows an attacker to craft a PDF file triggering an out-of-bounds write. This write can corrupt memory, crash the application, or serve as a vector for arbitrary code execution.

Affected Systems

Workstations running Apache OpenOffice 4.1.16 or earlier are affected. The issue is fixed in version 4.1.17.

Risk and Exploitability

The CVSS score is not provided and the vulnerability is not listed in the CISA KEV catalog, indicating limited public exploitation data. However, the flaw could be used to crash the program or achieve remote code execution if a user opens a malicious PDF, implying the likely attack vector involves social engineering to get the user to view the crafted file.

Generated by OpenCVE AI on November 4, 2026 at 12:56 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Apache OpenOffice to version 4.1.17 or later.
  • If an upgrade is not immediately possible, disable PDF import functionality or block malicious PDFs as a temporary control.
  • Ensure that only trusted, signed PDFs are accessible to users and conduct user training to recognize malicious files.

Generated by OpenCVE AI on November 4, 2026 at 12:56 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 04 Nov 2026 13:30:00 +0000

Type Values Removed Values Added
References

Wed, 04 Nov 2026 11:00:00 +0000

Type Values Removed Values Added
Description An unchecked memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 on allows a crafted PDF to execute an out-of-bounds memory write. This could crash the program or cause memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Title Apache OpenOffice: PDF File Parsing Heap based Buffer-Overflow-Remote Code Execution Vulnerability
Weaknesses CWE-787
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-11-04T12:13:21.921Z

Reserved: 2026-09-12T20:45:49.601Z

Link: CVE-2026-90624

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-04T11:17:18.970

Modified: 2026-11-04T13:17:32.800

Link: CVE-2026-90624

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T13:00:16Z

Weaknesses