Description
The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape some bundle configuration values before outputting them back in an admin page, allowing users with the translator capability and above to perform Stored Cross-Site Scripting attacks against high privilege users such as administrators.
Published: 2026-10-03
Score: 6.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Update Plugin
AI Analysis

Impact

The Loco Translate WordPress plugin, versions before 2.8.9, contains a flaw where certain bundle configuration values are saved and then displayed on an admin page without proper sanitisation or escaping. This allows any user who has the translator capability or higher to inject malicious scripts that will be executed in the browsers of privileged users, such as administrators, when they view the affected admin interface.

Affected Systems

All installations of the Loco Translate plugin for WordPress running any version earlier than 2.8.9 are vulnerable. WordPress sites that have the plugin deployed should verify the current version and apply the fix if required.

Risk and Exploitability

The vulnerability requires a user with translator-level or greater privileges to supply malicious configuration data. Based on the description, the attack vector is a stored cross‑site scripting path in the admin page. The EPSS score of < 1% indicates a very low likelihood of exploitation, while the CVSS score of 6.8 reflects medium severity. The vulnerability is not listed in CISA’s KEV catalog, so it is not currently known to be actively exploited.

Generated by OpenCVE AI on October 3, 2026 at 17:51 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Loco Translate plugin to version 2.8.9 or later to obtain the proper input sanitisation and output escaping.
  • Restrict the translator capability or remove any custom bundle configuration entries that can accept arbitrary input, thereby preventing the injection vector.
  • Disable or limit the use of the bundle configuration feature until the issue is addressed.

Generated by OpenCVE AI on October 3, 2026 at 17:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 04 Oct 2026 22:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions loco Translate
Vendors & Products Wordpress-extensions
Wordpress-extensions loco Translate

Sat, 03 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 6.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Sat, 03 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sat, 03 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape some bundle configuration values before outputting them back in an admin page, allowing users with the translator capability and above to perform Stored Cross-Site Scripting attacks against high privilege users such as administrators.
Title Loco Translate < 2.8.9 - Translator+ Stored XSS via Bundle Configuration
References

Subscriptions

Wordpress-extensions Loco Translate
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-03T15:12:20.905Z

Reserved: 2026-09-21T08:00:53.157Z

Link: CVE-2026-94239

cve-icon Vulnrichment

Updated: 2026-10-03T14:59:53.615Z

cve-icon NVD

Status : Deferred

Published: 2026-10-03T06:16:47.363

Modified: 2026-10-06T15:18:12.170

Link: CVE-2026-94239

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-04T20:50:30Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')