Description
The Pie Register WordPress plugin through 3.8.4.15 does not perform an authorisation check in one of its AJAX actions, allowing users with a role as low as contributor to modify existing administrator-created invitation-code records.
Published: 2026-11-08
Score: n/a
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

This vulnerability exists because the Pie Register WordPress plugin, up to version 3.8.4.15, lacks an authorization check on one of its AJAX actions. As a result, users with a role as low as contributor can modify invitation‑code records that were created by administrators. The flaw allows a non‑admin user to change data that is normally restricted to higher‑privileged accounts, potentially facilitating unauthorized access or impersonation. The impact is an elevation of privilege within the WordPress environment.

Affected Systems

Any WordPress site that has installed the Pie Register plugin at a version no later than 3.8.4.15 is affected. The vulnerability is specific to the plugin’s administrative invitation‑code functionality and is not tied to the core WordPress software.

Risk and Exploitability

The exploit does not require any special conditions beyond an authenticated contributor account, making it straightforward to execute. The EPSS score is not available, and the vulnerability is not listed in CISA’s KEV catalog, but the absence of a formal exploitation probability does not diminish the risk posed by an earnest attacker. The CVSS score is not supplied; nevertheless, the lack of an authorization check combined with the low role threshold results in a high severity risk in the absence of mitigation. The attack vector is most likely through the web interface via the injected AJAX request, and the vulnerability is exploitable from any location where the WordPress instance is reachable.

Generated by OpenCVE AI on November 8, 2026 at 07:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Pie Register plugin to the latest version that includes the authorization fix (CWE‑284).
  • If an upgrade is not feasible, disable the vulnerable AJAX action by deactivating the plugin or blocking the specific endpoint using a security plugin with URL filtering, thereby addressing the missing access control flaw (CWE‑284).
  • Modify or remove contributor and lower‑level capabilities to prevent execution of the protected AJAX action, using a role‑management plugin to mitigate the authorization issue (CWE‑284).

Generated by OpenCVE AI on November 8, 2026 at 07:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284

Sun, 08 Nov 2026 08:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions pie Register
Vendors & Products Wordpress-extensions
Wordpress-extensions pie Register

Sun, 08 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Pie Register WordPress plugin through 3.8.4.15 does not perform an authorisation check in one of its AJAX actions, allowing users with a role as low as contributor to modify existing administrator-created invitation-code records.
Title Pie Register <= 3.8.4.15 - Contributor+ Invitation Code Modification
References

Subscriptions

Wordpress-extensions Pie Register
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-08T06:00:29.071Z

Reserved: 2026-09-23T20:37:03.197Z

Link: CVE-2026-96963

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-08T06:17:05.890

Modified: 2026-11-08T06:17:05.890

Link: CVE-2026-96963

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T08:00:12Z

Weaknesses