Description
The Secure Custom Fields WordPress plugin before 6.9.8 does not re-apply its field-group location rules when persisting values submitted through the post editor save path, allowing users with contributor-level access and above to write custom fields the site restricted to administrators onto their own posts.
Published: 2026-11-08
Score: n/a
EPSS: n/a
KEV: No
Impact: Privilege Escalation on WordPress configuration
Action: Patch
AI Analysis

Impact

The Secure Custom Fields WordPress plugin, versions earlier than 6.9.8, fails to re‑apply field‑group location rules when saving custom field values via the post editor. As a result, users with contributor privileges or higher can create or modify custom fields that the plugin reserves for administrators, effectively allowing them to override site‑wide configuration stored in those fields. This unauthorized write leads to a loss of integrity for the protected configuration, enabling unintended data exposure or manipulation of site behavior.

Affected Systems

Any WordPress installation running the Secure Custom Fields plugin before version 6.9.8 is affected. The vulnerability is specific to this plugin; no other component is mentioned. Sites that rely on Secure Custom Fields for content or configuration should verify their plugin version and apply a fix if necessary.

Risk and Exploitability

There is no EPSS score or KEV listing, but the CVE description indicates the issue can be triggered by normal post‑editing actions performed by contributor users. Because the vulnerability permits direct writes to administrator‑reserved fields without additional authorization checks, the risk is high in terms of potential impact. The lack of exploitation data in public metrics suggests that the vulnerability is not yet actively used in the wild, yet the intrinsic severity warrants immediate attention.

Generated by OpenCVE AI on November 8, 2026 at 07:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Secure Custom Fields to version 6.9.8 or later.
  • If an update is not possible immediately, restrict the contributor role from editing custom fields by disabling the capability in WordPress or via plugin settings.
  • Disable or remove the Secure Custom Fields plugin until the patch is applied.

Generated by OpenCVE AI on November 8, 2026 at 07:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 09:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions secure Custom Fields
Vendors & Products Wordpress-extensions
Wordpress-extensions secure Custom Fields

Sun, 08 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284

Sun, 08 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Secure Custom Fields WordPress plugin before 6.9.8 does not re-apply its field-group location rules when persisting values submitted through the post editor save path, allowing users with contributor-level access and above to write custom fields the site restricted to administrators onto their own posts.
Title Secure Custom Fields < 6.9.8 - Contributor+ Admin-Restricted Custom Field Update via Post Save Path
References

Subscriptions

Wordpress-extensions Secure Custom Fields
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-08T06:00:28.025Z

Reserved: 2026-09-24T08:43:25.433Z

Link: CVE-2026-97192

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-08T06:17:06.003

Modified: 2026-11-08T06:17:06.003

Link: CVE-2026-97192

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T08:45:14Z

Weaknesses